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Unit One : Computer and operating systems 

Lesson One : computer system Basics 

1- Complete :-  

1- laptop, Desktop, Smart Devices are examples of computers 

2- Computer is an electronic set which has the ability to store data and process 

them to reach certain results {information} by doing logical and mathematical 

processes using series of logical arranged instructions called the program 

3- The main components of the computer system are  

 Data & Information, hardware , software and Humanware. 

4- Data can be text ,number ,character, image , video ,audio. 

5- Information may be in the form of reports, tables and charts. 

6- Hardware can be divided into Input Units , output units , Storage Units and 

System Unit.. 

7- Touch Screen is an input and output device in the same time. 

8- The important components of the system unit are The Main Memory , Processor 

and Motherboard. 

9- Storage unit is used to store data that can be retrieved (got back) at any time 

according to the user's need. The contents can't be lost when the electricity turns 

off, The most important storage units Hard disc and Flash Memory. 

10- The Main Memory is divided to: Random Access Memory (RAM)  

and Read-Only Memory (ROM). 

11- Byte  can be used in most computer systems as a unit of measuring data. 

12- The unit of measuring the processor speed is HZ. 

13- Bit: represents passing or not passing the electric current. It takes the value of 0 

or 1 as 1 represents passing the electric current (on) and 0 represents not passing 

the electric current (off). 

14- Byte = 8 bits a unit of measuring storage capacity 

15- Software consists of Operating system such as Linux and Windows  , Utilities  

such as Antivirus , Programming Languages such as C++ and Applications such as 

text editor programs. 

16- Humanware refers to Analyst , Designer , Programmer designer and User.  

17- Input devices are  Mouse , Keyboard , Scanner , Light Pen, Touch Pad , 

Graphics Pad and Joystick. 

18- Output devices are Monitor , Printer , and Speakers . 

19- 1 Kbyte = 1024 bytes (kilobyte) 
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20- 1 M byte= 1024 kbytes (Megabyte) 

21- 1 G byte = 1024 M bytes (Gigabyte) 

22- 1 T byte = 1024 Gbyte (Tirabyte) 

2- Write the scientific terms of the following: 

1- They are set of facts that can be obtained by observation or watching. 

These data can be text ,number, character, image , video ,audio..etc .. (Data ) 

2- Data are processed by classifying, organizing and analyzing to have sense to 

achieve certain goal (objective). They may be in the form of reports, tables and 

charts ……….. etc.        (Information) 

3- It is the actual content of the computer device which can be observed and 

touched. They include system unit, the screen, keyboard, the mouse………… etc  

          ( Hardware ) 

4- The devices and units which are responsible for inputting different data into the 

device.          (Input Units) 

5- The devices and the units which are responsible for outputting and displaying 

information and the results that the computer processed and executed according 

to the user's instructions.       (Output Units ) 

6- It is used to store data that can be retrieved (got back) at any time the according 

to the user's need. The contents can't be lost when the electricity turns off.  

           (Storage Units) 

7- It is responsible for doing any logical and mathematical processes which lead to 

data Processing according to the orders and instructions of the different programs.

        (Central Processing Unit (CPU) ) 

8- It is a set of programs used to operate the computer and employ 

it to do different tasks.        (Software) 

9- A type of programs where you can't read its source code. It is only available for 

programmers or designers.     (Closed Source Programs) 

10- They are the programs of source code available for use, editing, 

development and distribution.    (Open Source Programs) 

  



Computer and Information Technology                                                                               

First  Prep                                                    4                                                           First Term 2021/2022  

 

3- Compare between open and closed source programs:- 

 
 

 

 

 

 

 

 

 

 

4- Compare between RAM and ROM:- 

RAM ROM 

It is called work memory- it is memory of 
reading and writing. Its contents can be 
changes. Moreover, it is called the 
volatile memory as it loses its contents 
when the electricity turns off. 

It contains all the main programs to start 
the device on (BIOS). Its contents are 
saved by the producer company. It is 
called Read-only Memory because it is 
legible. Never can you write on. It is 
called the permanent memory because 
its contents are never affected by 
turning the electricity off and it can save 
its content permanently.  

Unit One : Computer and operating systems 

Lesson Two : Operating Systems 

Complete:- 

1- Operating system is the most important kinds of computer programs. 
2- Operating systems are responsible for managing Computer hardware , 

Applications and  Command prompt is where the user can prompt commands to 

operating system or through graphical user interface(GUI). 

3- Windows, Android, OS Mac for Apple, Fedora, Linux are different operating 

system. 

4- we can classify operating systems into Closed source operating systems, Open 

source operating system, Mobile phones operating systems. 

5- Mac OS X and Windows are from Closed source operating systems while Linux, 

Fedora, Ubuntu  are from Open source operating system.  
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6- There are open and closed source operating systems for mobile phones 

operating systems. On purchasing, operating systems and software applications 

are important factors especially when the technological specifications of mobile 

phones are approximated with each other. Android is one of the open-operating 

systems. It is not only used in Mobile phones but also in tablets. 

7- On starting the computer, operating system makes sure of the safety of main 

units such as temporary memory (RAM), Keyboard, screen and disc drivers. The 

self-test program which found in ROM can do that; In case of having no problems, 

operating system starts then, the opening screen appears for user to start 

achieving his work.  

2- Write the scientific terms of the following: 

1- It is a set of programs responsible for managing the hard ware of the 

computer. On one hand it is a means between the user and his programs and the 

hard ware on the other hand.     (Operating system) 

2- It contains some different commands and instructions in the form of 

menus,graphics , tool bars and basic input units such as the mouse that makes 

computer more interesting.         (Graphical User Interface (GUI) ) 

3-  It is an operating system specified for apple Mac devices that is attractive and 
easy to use.          (Mac OS X) 
4 Open source operating system – easy to use and developable.            (Linux) 
5- It is one of the open-operating systems. It is not only used in Mobile phones but 
also in tablets.            (Android) 
6- It is called "Terminal" in some operating systems where the user 

prompts commands to the operating system from command prompt keyboard.                  

          (Command Prompt) 

3- Put (√) or (×):- 

1-  There must be an operating system installed in the computer to be able to run 

the other types of different programs and applications and managing the Hardware 

of the computer.           (√) 

2-Operating system is the main structure of the computer system.  (√) 

3- The computer searches for operating system every time on starting inside one of 

the storage units (often C.D). Then, the main components are loaded inside RAM. 

Hence, the computer becomes ready to receive the user's command or 

instructions.           (√) 

4- There is similarity in GUI operating systems.      (√) 

5- Modern operating systems are distinguished with providing GUI for the user . (√) 
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6- The main components of the main screen aren't similar among the different 

operating systems.          (×) 

7- The computer can contain more than one operating system but on 

starting, choose one of them to be loaded.      (√) 

8- Operating system must be installed on the computer to be able to operating the 

rest kinds of different programs and applications     (√) 

9- The user can prompt commands and instructions of the operating system 
through command prompt.         (√) 

10- MAC OS X is one of the open source operating systems.   (×) 
11- Android is an open source operating system.      (√) 

Unit One : Computer and operating systems 

The Third Lesson : Dealing with files and folders 

1- Complete:- 

1- Files are the most important sources used on dealing with operating 

system; each text document , image , video or audio you deal with is a file. 

2- All processes carried out by the computer are kept inside RAM and when the 

electricity is off this temporary memory loses its contents  

3- File name consists of two syllables, the first is the origin name and the second is 

called extension which distinguishes file type. It often consists of three letters. The 

file origin name is separated from its extension with a (dot). 

4- The most important file types contain video files , image files , Text files and 

System files. 

5- There are several office programs such as MS office through which 

 text files are created. 

6- You can use "save as" to save the file with a new name at the same 

place or another. 

7- You can use the short keys in the keyboard (CTRL+S) to save the file. 

8- The purpose of using folders is an organized process for the storage units 
contents to reach the required files easily and quickly. 
9- To create a new a folder press Ctrl+Shift+N from keyboard. 
10- The folder may contain files or sub folders. 
11- To delete the folder: Use the context menu of the folder and click "Move to 
trash". 
12- To delete the folder forever:  Move to Trash, deleted files or folders appear 
then click "Delete from Trash ". 
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13- To restore the deleted file or folder:  Move to Trash, deleted files or folders 
appear then click "Restore from Trash". 
 

2- Write the scientific terms of the following: 

1- It Is a set of data which is stored in storage units in different kinds and 
extensions The user can deal with it on restoring, modifying, deleting, sharing and 
printing ……etc.            (File) 
2- This file contains sound and images. It is created by special programs for 
recording videos or audios.        (Video files)  
3- They are created by graphic programs including graphic data with different 
extensions which defines the image accuracy, clearance and size.      (Image files) 
4- They belong to the operating systems, programs and sets connected to the 
computer.These files mustn't be played with or deleted so as not to affect 
operating system work badly.               (System files) 
5- It is a place inside a storage device which contains a file or more and also 
other folders called sub-folder.               (Folder) 
6- Moving the folder from its current place to a new place at the same storage unit 
or any other storage unit.           )  Cutting the folder) 
7- Making  another instance to get spare copy of the file either at the same storage 
unit or any other.               (Copying the folder) 

3- Put (√) or (×):- 

1- The file has certain types which differ according to the application used in its 

creation.            (√) 

2- At the first time to save files the command save is similar to save as command.  
(√) 

3- It is preferred to file name to suit its content to be easy to remember. (√) 
4- To keep your doings permanently, you should save them in the file on a storage 
unit.             (√) 
5- Any deleted folder or file can move to trash (the basket where deleted files or 
folders exist) where it can be restored again or deleted forever.   (√) 
6- The type of the file can be identified through its icon or extension.      (√) 
7- The permanent delete in Trash can be restored again.         (×) 
8- Cut and paste of the folder means repeating it to get a spare copy either 
at the same storage unit or at another.       (×) 
9- Files can be saved by using (Shift + S).       (×) 

4- Re-arrange The following storage units according to the 

storage capacity (descending) from big to small:- 

(2) Flash Disk 
(3) CR-ROM 
(1) Hard Disk 
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5- Re-arrange the following steps to save a file:- 

(4) Define the place in which file be saved. 
(1) Open file menu. 
(3) Write the file name in the specific place. 
(2) Chose save as, save as dialogue box appears. 
(5) Click save. 

6- Re-arrange the following steps to change the folder name:- 

(2) Write the new name. 

(1) Click "Rename" command from context menu. 

(3) Click "Rename". 

7- Re-arrange the following steps to create a folder:- 

(3) write the folder name. 

(1) Click the mouse in the place where you need to set up the folder. Click 

      the right button of the mouse, the context menu appears as found in the  

      following shape. 

(4) Click "create". 

(2) Select the "New folder" command 
 

8- Re-arrange the following steps to copy a folder:- 

(1) Choose "copy" command from context menu. 

(3) display the context and choose "paste" command then the folder is  copied. 

(2) Move to the new place (the same storage unit or the other) 

9- Compare between save command and save as command:- 

 

 

 

 

 

 

 

 

Unit One : Computer and operating systems 

The Fourth Lesson : The Computer Networks 

1- Write the scientific terms of the following: 

1- It is a connection between two sets or more through a wire or wireless means to 
share the resources (sets and data).    (The computer net) 
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2- It is a limited network area inside a building or several near buildings. It is used 
at small institutions, schools, universities or at home. 
             ( Local Area Network (LAN) ) 
3- It is used to connect devices separated by long distances like cities, states or 
continents, so other methods are used to connect devices that are different from 
the local network. The Internet is considered a special type of the wide area 
networks.            (Wide Area Network (WAN) ) 
4- It is the process of spreading digitally stored information, such as 
documents, electronic books, computer software or multimedia (audio files, video 
or photos). This is to help accessing any of them through computer networks where 
any files can be shared as well as some of the devices such as a printer among 
different network devices.        (File Sharing) 

2- Complete:- 

1- Local Area Network (LAN) and Wide Area Network (WAN) are types of 
networks. 
2- Using the permission of Read/Write may cause a problem as it allows others 
through the network to change the content shared as well as deleting it totally 
from your device which may cause damage, falsification or missing the information. 
from your device which may cause damage, falsification or missing the information. 
3- Implementing the file sharing in Fedora Operating System could be through 
allowing the users of the network to access a folder entitled Public in the folder 
Home through other computer devises connected to the same 
network.Consequently, add all the files required for sharing in the Folder Public. 
 

3- What are the steps to access a folder (folders) which was 

shared through the network :- 

(1) Double Click on the computer network icon (Network), the window which 

includes all the computers who are connected to the network appears. 

(2) Search for the required device through its name. By double clicking the 

mouse, you can access the device then all the shared folders appear . 

4- Re-arrange the following steps to know the name of your 

computer:- 

(2) Click on the option "Properties". 

(1) Show the context menu of the "Computer" icon on the desktop. 

(3) The name of the computer is displayed in the item "Computer name". 

5- What are the steps to share a file or a group of files in 

Windows Operating system:- 

(1) Add the files in a folder. 
(2) Select the folder to be shared (for example the folder, Books), right-click 
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the mouse then select "Share with" from the context menu. 
(3) Select the option “Specific people”, a dialogue box "File Sharing" appears . 
(4) Choose the user allowed to share the folder from the drop down list. Let the 
user be "Everyone" to allow all the users to share the specified folder. 
(5)Press the button "add" to add this user to the list of users allowed to share. 
(6) Different permission can be assigned through Permission level where the choice 
"Read" means allowing reading the files only and the choice "Read/write" means 
allowing reading, modification or deletion. 
(7)Press "Share" to complete fulfilling sharing the folder with special validations. 

6- What are the steps to allow others to access the contents 

of the folder Public in Fedora Operating System:- 

(1) Click "Activities" which appears on the top ribbon of Fedora opening screen. 

(2) Start by writing the term "Sharing" in the search box so the Sharing icon 

appears. 

(3) By clicking on the "Sharing" icon a window of configuring the sharing settings is 

shown. 

(4) Reset the "sharing" button on the top right of the window to the ON position. 

(5) Reset "Personal File Sharing" also to the ON position. 

By doing that other users of the same network can have access to your folder 

Public through their devices accordingly, they can access the files inside it. 
 

7- Put (√) or (×):- 

1- Linking devices together within a computer network gives the possibility of 
sharing the data only.          (×) 
2-The Internet is considered a special type of wide area networks   .           (√) 
3-The wide range network uses different methods than that of the local network to 
maintain connectivity.                                                                        (√) 
4-To share folders, your device must be connected to the network to help other 
users to reach it  .            (√) 
5- Using the permission of Read allows others through the network to change the 
content.            (×) 
6-To share files in Windows Operating System, It is not necessary to be added in a 
folder  .                           (√) 
7- Specifying the user Everyone to share a folder in Windows Operating System 
means allowing all users to share it  .              (√)  
8- The Computer icon is used to access the shared folders in Windows Operating 
System.                         (×) 
9- Sharing files in the Fedora Operating System is to be implemented through 
allowing the network users to access a folder Document .                            (×) 
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10- To make the process of sharing files accessible in Fedora Operating System, the 
sharing setting must be set upon an Off position.             (×) 

8- Complete the sentences using the words between brackets 

)files - size - data - users - the name - research – devises( 
1- One of the most important benefits of the network is centralizing data 
2- The local network is a limited network in the size 
3- Sharing files is a process of spreading digitally stored information. 
4- Searching for accessing required device on the network is to be through the 
name 
5- It is possible to other users to access the files that you shared through 
accessing your folder Public. 
6. The term Sharing is written in t research dialog box to access the Sharing icon. 

Unit (2)          Creating and Modifying images 

Lesson (1) : Introduction to the basics of creating and modifying images 

1- Complete:- 

1- There are various programs to create and modify images such as Adobe 
Photoshop which is from closed source program and Gimp program which is from 
open source program. 

source that allows creating an and free openprogram is an  GIMPThe  -2 
processing images. 
3- The Interface of the GIMP program is available in two forms : 

Multi-window mode and Single window mode 
4- When opening the GIMP program for the first time,it is usually on the multi-
window mod - To facility the using the program, It could be in the Single window 
mode from the Windows menu then select Single-Window Mode and after closing 
the program and reopening it,it remains in the Single-Window Mode. 
5- The selection tools are Rectangle selection Tool, Ellipse Selection Tool, Lasso 
free selection Tool, Fuzzy Selection (Magic Wand) tool and Smart Scissors 
Selection tool. 
6- The selection tools are shown in The Main Toolbox you can also access it 
through the Tools menu and select Selection Tools. 
7- To finish the selection and exit: From the Select menu Select None or from the 
keyboard, click the  Shift + CTRL + A. 
8- To cut a part from the image: from the Edit menu choose Cut. 

2- Write the scientific terms of the following: 

1- They used to assist in designing, creating and modifying different images. It 
enables the user to modify photos or drawings. There are many of those programs 
which are a closed and open source programs. 
    (The programs of creating and modifying images) 
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2- It consists of many tools such as the selection tools, back and front 
color tools.... in Gimp program.     (The Main Toolbox ) 
3- They  are used to select a part or more of the image to deal with, like delete, cut, 
copy, paste, change the color of the selected part in order 
not to change the whole image.     (The selection tools ) 
4- A tool is used to select the oval shape of the image.(The Ellipse select tool) 
5- A tool is used to select an irregular part of the image in a free way. 
        (The Lasso Free Selection tool) 
6- A tool is used to specify similar color schemes areas of the image. 
     (The Magic wand tool or Fuzzy Selection tool ) 
7- A tool is considered a useful tool when trying to specify an area specified or 
distinguished with a clear and strong color where the colors of the borders are 
changed in a clear manner. To use this tool, click on the points by pushing the area 
with distinguished color from the rest of the other ones.     
        (The Smart Scissors selection tool ) 

 

3- Put (√) or (×):- 

1- You can choose the selection tool "Rectangle" by clicking on the tools box. 
to select it, click by pushing the image in the selected place so a rectangular is 

drawn in the image.          (√)  

2- You can draw the lines with the "Pencil" tool inside the selection only.    (√)  

3- On opening the GIMP program for the first time the program is shown 

in the multi window- mode.              (√) 

4- The "Pencil tool" is considered one of the selection tools.   (  × ) 

5- The Lasso tool is used to select an irregular part of the image in a free way.(√) 

6- The "Ellipse" selection tool is used to select an oval shape of the image.  (√) 

Compare between the shape        and the shape         :- 

the shape the shape 

The cursor outside the selection area 

that takes the shape of                 by 

clicking and pushing the selection place 

is changed. 

The cursor in the selection area that 

takes the shape of           where you can 

move the selection rectangle 

Lesson (2)    Designing and creating new images 

1- Write the scientific terms of the following: 

1- They are ready made designs previously prepared of the dimensions and the 
resolution of the picture in the dialogue box. by clicking on the drop down list it 
appears to select from instead of selecting manually.   (Templates) 
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2- It is used to identify the dimensions of the new image (length and width) in the 
dialogue box click on the arrows .      (Image Size) 
3- It is used to specify the new image filling color in the dialogue box. (Fill With) 

2- Complete:- 

1- To create a new image file (New Image) from the File menu choose New, a 
dialogue box appears which requests the dimensions of the new image (length and 
width), its resolution, color scheme and its filling color. 
2- To save image select Save from the File menu, since the GIMP program offers 
the extension XCF to the image file, to save all the information about the image 
(Layers. Transparency) This extension is useful in case of reopening the file of the 
image or modifying it. 

3- What are steps of creating a new image of (600 X 800) and 

fill its background color:- 

1- to choose another color of the background click on the toolbox of 
Background Color in the dialogue box. 
2- A dialogue box "Change Background Color" is opened, to change the background 
color: do the following:- 
 - click by pulling to change the current background color. 
 - Current: Is the color of the current background, click ok. 
3- From the File Menu Choose New, A dialogue box  
of a new image appears to choose the following: .  
 - From Template Choose 600 X 800 
 - From Fill with Choose Background Color. 
 - Click "OK". 

4- What are steps of trying implement the next drawing:- 

1- Create a new file from the File menu and select New, a dialogue box appears to 
select the dimensions of the new image. 
2- Choose the "lasso" free selection tool to draw the  
abbreviation "EG" as follows: 
 - To draw the first letter "E" click by pulling the free selection tool  
           until the completion of drawing the letter. 
 -To draw the second Letter "G", it should be noted that when you  
            click by pulling to draw it the first letter "E" disappears. 
 - To keep the previous specified selection of the "Lasso" free  
             selection tool click on to "Add to current Select." 
 - Choose the color filling "Bucket Fill" Tool, click inside this selection  
            to fill it with the front color. 
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5- What are steps of drawing an oval shape with green 

colored borders and fill it with a yellow color:- 

1- To open a new file image from File menu select new. 
2- Select the Ellipse selection tool. 
3- Select the green as front color from the tool box. 
4- From the Edit menu choose "Stroke Selection", a "Stroke Selection" dialog box 
appears. 
5-  Select the line width from "Line width" from the dialog box. Click on "Stroke", 
the borders of the oval shape are drawn with the green color 
6- Select the yellow as front color from the tool box. 
7-From the Edit menu select Fill with FG Color; the selection is filled with the front 
color with yellow. 

Lesson (3)     Paint Tools 

1- Complete:- 

1- The Paint Tools that can be accessed from the Tools menu or from the Tools 
Box. 
2- The paint tools are Pencil Tool, Blend Tool, Smudge Tool , Clone Tool,  
3- The pen in the "Pencil" tool is used for free hand drawing. 
4- The Blend tool is used to make color gradation using the front or back colors. 
Modifications are made to the options of the tool to get the gradient color scheme 
required. 
5- The Smudge Tool is used to mix the current color with the surrounding colors in 
the area of moving the tool. 
6- The Clone tool is used to copy part of the picture in another place (in the same 
image layer). It is used to modify and reform the images. 
7-We use the Ink tool like a fountain pen to control drawing distinguished 
borders and edges with the brush. 
8- We use the Eraser tool to remove a coloring Space of a picture or a drawing. 
9- We use the Paintbrush tool to draw clearly. 

2- Put (√) or (×):- 

1-  Use the Pencil tool to make a free hand selection.    (×) 
2-The Clone tool used to mix the current color with the surrounding colors in the 
space where the tool is moving.       ×) ) 
3-One of the selection tools is the Blend tool.     (×)  
4- The Smudge tool is used to copy part of the image in another place in the 
same image layer, it is well known for modifying and reforming images .(×) 
5- Paint tools are used for different drawing purposes such as free hand drawing, 
create gradient color scheme.        (  √ ) 
6. The Eraser tool is used to delete a color space of a picture or an image.(  √ ) 
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Lesson (4)   Transforming and resizing tools 

1- Complete:- 

1 - Transform tools are the tools used to change the image format either by 
transforming, resizing, changing the image dimensions .to access the tools of the 
Transform tools go to the tools menu, or through the square tools . 
2- The Move tool is used for moving the image or the layers of an image to frame 
or text. 
3- To move a selection, press ALT + CTRL, continue pressing using the Move tool to 
move the selection. 
4- Crop tool is used to crop part of an image. 
5- Rotate tool is used to rotate an image. 
6- Flip Tool is used to horizontally or vertically flip an image. 
7- Scale tool is used to change the dimensions of an image. 

2- Put (√) or (×):- 

1- Transform Tools are used to change the form of an image through 
move, resize or change dimensions.       (√) 
2-Move Tool is used to move an image or image layers or selection or text ( . √)  
3-To move, press Alt + CTRL and continue pressing using the Move tool ( .√ )  
4- Rotate tool is used to crop part of an image.      (×) 
5- Gimp program consists of the selection tools and paint tools only.  (×)  
6-Crop tool is used to rotate an image.       (×) 
7-Scale tool is used to make horizontal or vertical flip of an image.  (×)  
8- Flip tool is used to make change an image dimensions [length, width].  (× ) 
9- Clone tool is from transforming and resizing tools.     (× ) 
 

Lesson (5)      Image Layers 

1- Complete:- 

1-Layer visibility : to make the layer visible  or nonvisible. 
2- Layer thumbnail :is a mini format of the 
 layer and the layer name appears next to 
 it (and can be changed by clicking on it). 
3-New layer :to add a new layer . 
4-Raise layer :to move the layer to the  highest level. 
5-Lower layer: to move the layer to a lower  level. 
6- Duplicate layer : to copy the current layer. 
7-Delete layer :to delete the current layer. 
8- We use the "Layers" tab to edit, add and control different picture layers. 
9-  You can get to the "Layers" tab through:The main interface of the program or 
through Windows menu then select Dockable Dialogs and select  Layers. 
10- To deal with the layer, it must be pressed to become the current active Layer. 
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11- To add a new layer, click on the New layer in the "Layers" tab, the dialog "New 
Layer" Will appear then press OK. 
12- To make the image layer invisible, click on the Layer visibility icon, and then the 
layer disappears, to reshow the layer content, click the layer visibility icon again. 
13- To rename the layer, double click on the layer and give it a new name. 
14- To make the image liable to delete part of: from the list of Layers select 
Transparency and then choose Add Alpha Channel ,The Alpha Channel represents 
the transparency of the image. 

2- What are the steps of exporting image to a file with an 

appropriate extension? 

1- Ensure that all layers are Visible. 
2- integrate all layers, and to merge the layers into a single layer, choose "Flatten 
Image" of the "Image" menu. 
3- From the "File" menu choose "Export", select the appropriate extension of the 
file and its name. 
 

2- Put (√) or (×):- 

1- We click on Duplicate layer  to copy the current layer.    (√) 
2- To make the layer visible  or nonvisible, click on Layer thumbnail.   (×) 
 

3- What are the steps of making a shadow for the following 

picture? 

1- Select the white color in the original image using Fuzzy tool; the white space 
around the flowers is selected. 
2- Press "Delete" key from the keyboard, then selected 
 white space around the flowers is cleared. 
3- Insert a new layer with name "Shadow." 
4- from the list "Select", Choose "Invert" to invert the 
 selection and determine the shape of flowers. 
5- Make sure that the new layer "Shadow" is the  
current layer. To change the foreground color in gray - Use the Bucket Fill tool to 
make color packing in gray inside flowers selection. 
6- Rearrange the layers so that the layer "Shadow" is the bottom layer. 
7-To end the selection, from the "Select" menu, choose "none". 
8- Move the upper layer of the flowers using the Move tool to show the shadow. 

Lesson (6)    Edit image using filters 

Complete:- 

1- A Filter is used to help change the appearance of an image. 
2- To use a filter , select the suitable filter from the Filters menu. 
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3- The filter "Blur"  is used to wipe out or darkening the image:from Filters menu 
select Blur then select Blur. 
2- Put (√) or (×):- 
1- A filter is used to help change the appearance of an image.   (√) 
2- The filter "Blur" is used to change the appearance of an image to old photo.(×) 
3- To use filter, from the “Filters” menu, select the suitable filter.   (√) 
4- When we use ‘Filters”, a new layer is added or a new file is created.   (√) 

Lesson (7)                            Image Types 

Complete:- 

1- Image types are Raster Images and Vector Images. 
2- You can change the status or condition of the color image through the Mode 
command in the Image menu,namely RGB mode, Grayscale mode and Indexed 
mode. 

Indexedby using a command  Indexed modeYou can convert the image to  -3 
from Image list. 
4- To save image in Gimp program: select Save command from the File menu 
where GIMP program gives extension to the image file .XCF, where all information 
about the image (its layers, transparency …) is kept.  
5- To be able to read the image file, the image must be exported through the 
Export command from the File menu where the appropriate image file extension 
such as (JPEG -GIF - PNG ...) is selected. 

2- Write the scientific term:- 

1- It consists of contiguous points (Pixels), and each image contains rows and 
columns of the Pixels and the higher the number of the Pixels, the greater image 
clarity is, It has a large storage area for the image, and the quality and clarity of the 
picture change when zooming in or out.    (Raster Images ) 
2- It is characterized by no change in image quality and clarity when enlarged 
or minimized, and it has a small storage area.   (Vector Images ) 
 
3- It consists of the primary colors (red, green and Blue), and these 
three colors are mixed and united with different degrees of mitigation, lighting and 
intensity to give each primary color of these colors 256 color degree.(RGB mode ) 
4- The image can be converted to the color gray case by using the command 
Grayscale from Image list, where Grayscale mode reaches up to 256 degrees of 
gray ranging from black to white.         (Grayscale mode ) 
 

3- Put (√) or (×):- 

1-In the Vector Image, the quality and clarity of the picture change when zooming 
in or out .              )×(    
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2- Copy Raster Image is characterized by no change in image quality and clarity 
when enlarged or minimized .       )×(     
3- There is only one color mode of the image .     )×(    
4-RGB mode fits very much in the case of display images and graphics through the 
computer screen  .          (√)  
5- RGB mode consists of the primary colors (red, green and black)  .  )×( 
6- You can convert the image to the color grayscale using the Grayscale command. 
            (√)  
7-The image must be exported through the Import command from File menu. (×) 
8-You can convert the image from RGB mode to Grayscale mode where the image 
loses its Colorimetric data.        √) ) 
9-In order for other software to read the image file, the image must be exported 
through the Save command from the File menu .    )×(  
10- The image can be converted from RGB mode to Grayscale mode. √) ) 
11. The large size storage area is from the Vector Image defects .  )×( 
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Practical Questions 

1- What are the steps to create a new folder on the Desktop 

named "School"? 
The answer 

 (1) Click the mouse in the place where you need to set up the folder. Click the 
right button of the mouse, the context menu appears . 
(2) Select the "New folder" command             (3) write the folder name . 

2- What are the steps to know the name of your computer? 

The answer 
 (1) Show the context menu of the "Computer" icon on the desktop. 
(2) Click on the option "Properties". 
(3) The name of the computer is displayed in the item "Computer name". 

 

3- Create a new folder on the Desktop named "Salam" then 

share the folder through the network. 

The answer 
 (1) Click the mouse in the place where you need to set up the folder. Click the 
right button of the mouse, the context menu appears . 
(2) Select the "New folder" command 
(3) write the folder name . 
 (4) Select the folder to be shared "salam", right-click the mouse then select "Share 
with" from the context menu. 
(5) Select the option “Specific people”, a dialogue box "File Sharing" appears . 
(6) Let the user be "Everyone" to allow all the users to share the specified folder.                                    
(7)Press the button "add". 
 

4- What are the steps of creating a new image of (600 X 800) 

and fill its background color in Gimp program? 

The answer 
1- To choose another color of the background click on the toolbox of 
Background Color in the dialogue box. 
2- A dialogue box "Change Background Color" is opened, to change the 
background color: do the following:- 
 - click by pulling to change the current background color. 
 - Current: Is the color of the current background, click ok. 
3- From the File Menu Choose New, A dialogue box of a new image appears to 
choose the following: . - From Template Choose 600 X 800 
 - From Fill with Choose Background Color.         - Click "OK". 
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5- What are the steps of trying implement the next drawing? 

The answer 
1- Create a new file from the File menu and select New, 
 a dialogue box appears to select the dimensions of the new image. 
2- Choose the "lasso" free selection tool to draw the abbreviation "EG" as 
follows:  - To draw the first letter "E" click by pulling the free selection tool  
           until the completion of drawing the letter. 
 -To draw the second Letter "G", it should be noted that when you  
            click by pulling to draw it the first letter "E" disappears. 
 - To keep the previous specified selection of the "Lasso" free  
             selection tool click on to "Add to current Select." 
 - Choose the color filling "Bucket Fill" Tool, click inside this selection  
            to fill it with the front color. 

6- What are the steps of drawing an oval shape with green 

colored borders and fill it with a yellow color? 

The answer 
1- To open a new file image from File menu select new. 
2- Select the Ellipse selection tool. 
3- Select the green as front color from the tool box. 
4- From the Edit menu choose "Stroke Selection", a "Stroke Selection" dialog 
box appears. 
5-  Select the line width from "Line width" from the dialog box. Click on 
"Stroke", the borders of the oval shape are drawn with the green color 
6- Select the yellow as front color from the tool box. 
7-From the Edit menu select Fill with FG Color; the selection is filled with the 
front color with yellow. 
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7- Open any image from your computer in Gimp program then 

do the following :- 

1- Mix the current color with the surrounding colors in the area of 
moving the tool. 
2- Copy part of the picture in another place (in the same image layer). 
3- Crop part of the image. 
4- Rotate the image. 
5- Flip the image. 
6- Change the dimensions of the image. 

The answer 
1- Choose Smudge tool  - Choose the (shape and size of the brush) from the 
tools options  - by clicking and pulling the tool in the picture to mix the current 
color with the surrounding colors. 
2- To copy part of the picture in another place: Choose the Clone tool - stop 
the cursor at the beginning of the place required to be copied -  press the 
"CTRL" key on the keyboard - move to the required place to add the copied 
version-click by pulling to create the copied version- do not stop clicking and 
pulling till you complete the copying. 
3- To crop part of the image: Select Crop - Drag and drop the image to select 
the needed part - Press Enter from the key board. 
4- To rotate the image: Select Rotate - Drag and drop to rotate the image 

- Press Enter from the keyboard after finishing. 
5- To make horizontal or vertical flip, select Flip tool then from Tool Options 
dialogue box, select an option. 
6- To change the dimensions of the image: Select Scale Tool  - Press on the 
image to show the dialog box to decide the dimensions and image 
Corners - Drag and pull to change the dimensions of the image through the 
dialog box - Press Enter from the keyboard when you finish. 
 
 


